出现 java.lang.UnsupportedClassVersionError 错误的原因及解决方法

1 原因

  对于出现java.lang.UnsupportedClassVersionError错误的原因,大都是因为我们编译java.class文件的 JDK 和我们运行java.class文件的 JDK 的版本不同而产生的。不同的 JDK 版本之间,特别是高版本 JDK 编译的java.class文件在低版本的 JDK 上运行,更容易造成低版本的 JDK 无法识别的问题,从而报出此错误。

  此外,在 Maven 项目中,也有可能出现java.lang.UnsupportedClassVersionError的错误,同样是因为版本不同而产生无法识别的错误。不过,在 Maven 项目中造成这样错误的原因可能是不同的 Maven 版本与不同的 java JDK 的版本之间产生的原因,例如,maven 3.3.1+的版本只能运行在java JDK 1.7+的版本上。

2 解决方法

  知道问题产生的原因,那么解决方法就很简单了,更换 JDK 或者 Maven 的版本就可以啦!

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 代码科技 设计师:Amelia_0503 返回首页
实付 9.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值